
Operating Instructions

Printer Driver for Cloud Print





How to Read This Guide
We recommend that you read this guide in its entirety to familiarize yourself with how to utilize the
printer driver and port monitor for cloud printing.

Symbols

The following symbols are used in the manual to help you to identify content quickly.

This symbol indicates points to pay attention to.

This symbol indicates supplementary information that you may find helpful for completing a task.

[ ]

Square brackets indicate the name of buttons or fields.
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Important
• TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW:

• THE SUPPLIER SHALL NOT BE LIABLE FOR THE RESULT OF OPERATION OF THIS
SOFTWARE OR THE USE OF THIS DOCUMENT.

• THE SUPPLIER SHALL NOT BE LIABLE TO YOU FOR DAMAGES OR LOSS OF ANY
DOCUMENT OR DATA PRODUCED BY USING THIS SOFTWARE.

• THE SUPPLIER SHALL NOT BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL
OR INDIRECT DAMAGES (INCLUDING, BUT NOT LIMITED TO, DAMAGES FOR LOSS OF
PROFITS, BUSINESS INTERRUPTION OR LOSS OF BUSINESS INFORMATION, AND THE
LIKE) CAUSED BY FAILURE OF THIS SOFTWARE OR LOSS OF DOCUMENTS OR DATA,
NOR FOR ANY OTHER DAMAGES ARISING OUT OF THE USE OF THIS SOFTWARE, IF
THE SUPPLIER HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

• Some illustrations or explanations in this guide may differ from your product due to improvement or
change in the product.

• The contents of this document are subject to change without notice.

• No part of this document may be duplicated, replicated, reproduced in any form, modified or
quoted without prior consent of the supplier.

• It is possible that any document or data stored in the computer will be damaged or lost by user
error during operation or software error. Be sure to back up all important data beforehand.
Important documents and data should always be copied or backed up. Documents and data can
be lost because of malfunction or human error. Furthermore, the customer is responsible for
protection measures against computer viruses, worms, and other harmful software.
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1. Introduction
This guide describes how to install/uninstall the printer driver and port monitor for cloud printing to/from
a client PC, how to register/delete the port for cloud printing, and how to send a print job using a
printer driver.

Workflow
For setting and utilizing the printer driver and port monitor for cloud printing, there are operations which
require the administrator authority, and operations which are available for user authority.

This guide describes the operations respectively by following the workflow below.

Operations for Administrators

Administrator authority is required for installing/uninstalling printer driver and port monitor for cloud
printing.

Setup

• To install a printer driver and port monitor for cloud printing

For details, see page 9 "Installation".

Maintenance

• To uninstall the printer driver and port monitor for cloud printing

For details, see page 13 "Uninstallation".

Operations for Users

Setup

• Checking that the port is set for the printer driver

For details, see page 12 "Checking That the Port is Set for the Printer Driver".

Maintenance

• To send print jobs

For details, see page 15 "Sending a Print Job to the Server of Cloud Printing".

• Setting the User Information*

For details, see page 17 "Setting the User Information".

* This operation is required when sending a print job for the first time after a client computer starts.
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Overview of Printer Driver for Cloud Print
You can send a print job to the server of cloud printing using an application used on a client PC, when
the printer driver for cloud print is installed.

When you use the Windows PC, you must register the port for cloud printing to the printer driver.

Managing user 
information etc.

Viewing/printing/
deleting print jobs

UserUser

Multifunction printer that can use 
the cloud print service

Cloud Server of RICOH Smart Integration

Storing print jobs
Authentication of a 
tenant and users 

DSGVIX3011

Sending print jobs using 
a printer driver

Client computer with port monitor and 
printer driver for cloud print installed

Administrator
Administrator’s 
Computer

Operating Environment

The following environment is required for installing the printer driver and port monitor for cloud print,
and sending a print job to the server of cloud printing.

• Internet environment is required for sending a print job to the server of cloud print using a printer
driver.

1. Introduction
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CPU

According to the specifications recommended for each Operation System

Memory

According to the specifications recommended for each Operation System

HDD

Free space of 500 MB or more

Operating system

Windows

Windows 10 Home (32bit/64bit)

Windows 10 Pro (32bit/64bit)

Windows 10 Enterprise (32bit/64bit)

Windows 11 Home

Windows 11 Pro

Windows 11 Enterprise

macOS

macOS 10.13 High Sierra

macOS 10.14 Mojave

macOS 10.15 Catalina

macOS 11 Big Sur

Google Chrome OS

89.0.4389.82 or later

Printer driver

Windows

PCL 6 Driver for Universal Print

macOS

PS Generic driver

Chrome OS

-

Overview of Printer Driver for Cloud Print
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Data size

Up to 300 MB (per file)

If a print document exceeds 300 MB in size, an error message is displayed and the document is not sent
to the server of cloud print.

• The data size (300 MB) is applied to the print job generated by a printer driver. The data size of a
print job can be confirmed in a print queue of a printer.

• For the update information of the operating environment, refer to the Ricoh’s cloud print service site.

Number of print jobs that can be stored

Up to 50 files

1. Introduction
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2. Installation
This section describes how to install the printer driver and port monitor for cloud printing to a client PC.

Installing a Printer Driver and Port Monitor

For Windows

• To install a printer driver and port monitor exclusively for cloud printing, administrator privileges
are needed.

Using "Application Settings(General Users)" to install an installer

1. Access RICOH Cloud Service.

2. Click [Application Settings(General Users)].

3. Click [Download].

4. Click [Printer Driver for Cloud Printing].

5. Click [WindowsOS].

6. Click [Download].

Each of the provided installers are pre-configured to use a different user authentication
method. Use the appropriate installer for the user authentication method that you want to use.

7. Specify the location to save the file, and then save.

8. Execute the downloaded exe file.

The printer driver and port monitor are installed.

Using FlexRelease CX to download an installer

1. Access RICOH Cloud Service.

2. Click [FlexRelease CX].

3. Click [Printer Driver].

4. Click [WindowsOS].

5. Click [Download].

Each of the provided installers are pre-configured to use a different user authentication
method. Use the appropriate installer for the user authentication method that you want to use.

6. Specify the location to save the file, and then save.

7. Execute the downloaded exe file.

The printer driver and port monitor are installed.
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• For Windows, when a user account control message appears during installation, click
[Yes].

• For Windows, If the Windows protected your PC dialog box appears during the
installation and the installation stops, click [Run anyway] in the "More info" dialog box.

For macOS

• To install a printer driver for cloud printing, administrator privileges are needed.

Using "Application Settings(General Users)" to install an installer

1. Access RICOH Cloud Service.

2. Click [Application Settings(General Users)].

3. Click [Download].

4. Click [Printer Driver for Cloud Printing].

5. Click [MacOS].

6. Click [Download].

Each of the provided installers are pre-configured to use a different user authentication
method. Use the appropriate installer for the user authentication method that you want to use.

7. Specify the location to save the file, and then save.

8. Execute the downloaded dmg file.

9. If you are using a proxy server, check "Use a Proxy Server" and configure the proxy
server settings.

10. Enter your credentials into "Login", and then click Install.

The printer driver is installed.

Using FlexRelease CX to download an installer

1. Access RICOH Cloud Service.

2. Click [FlexRelease CX].

3. Click [Printer Driver].

4. Click [MacOS].

5. Click [Download].

Each of the provided installers are pre-configured to use a different user authentication
method. Use the appropriate installer for the user authentication method that you want to use.

6. Specify the location to save the file, and then save.

2. Installation
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7. Execute the downloaded dmg file.

8. If you are using a proxy server, check "Use a Proxy Server" and configure the proxy
server settings.

9. Enter your credentials into "Login", and then click Install.

The printer driver is installed.

• For information about how to set the user and proxy connection information, see
page 17 "Setting the User Information".

• If an attempt to connect to the cloud server fails, the installation is interrupted with an
error message.

For Google Chrome OS

You can add "Ricoh Cloud Print" using Chrome extensions.

1. Access to chrome web store, and then search "Ricoh Cloud Print".

2. Click displayed "Ricoh Cloud Print".

3. Click [Add to Chrome].

4. Click [Add extension].

Ricoh Cloud Print has been added to Extentions.

Installing a Printer Driver and Port Monitor
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Checking That the Port is Set for the Printer
Driver
You can check that the port is set for the printer driver when you use the windows PC.

• The procedures to open the properties screen for a printer driver differ depending on the operating
system of a PC. Perform the procedures accordingly instead of the steps described below.

1. On the [Start] menu, click [Devices and Printers].

2. Right-click the [RSI Cloud Printer] icon, and then click [Printer Properties].

3. Click the [Port] tab.

4. Check that [FRCX port] is displayed and selected.

5. Click [OK].

2. Installation
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3. Uninstallation
This section describes how to uninstall the printer driver and port monitor for cloud printing from a client
PC.

Uninstalling the Port Monitor for Cloud Printing
You can uninstall the port monitor for cloud printing when you use the windows PC.

• Administrator authority is required for uninstalling the port monitor for cloud printing.

1. Close all the applications currently running on a client PC.

2. On the [Start] menu, click [Windows System] > [Control Panel] > [Uninstall a program].

3. Select [FRCX port], and then click [Uninstall].

4. Click [Yes].

5. Click [Finish].

• When a user account control message appears during uninstallation, click [Yes].

• When uninstallation of cloud printing-exclusive port monitor is complete, the port assigned to the
printer driver is automatically unassigned. When this unassignment occurs, "LPT1: Port" is now
reassigned to the printer driver.

• If the port monitor for cloud printing is uninstalled while sending a print job, the transmission will
fail.
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Uninstalling the Printer Driver

• Administrator authority is required for uninstalling the printer driver from Windows or macOS.

For Windows

1. On the desktop, click [Start] > [Windows System Tools] > [Control Panel] > [Devices and
Printers].

2. Select [RSI Cloud Printer], and then click [Remove Device].

3. Click [Yes].

For macOS

1. Select [System Preferences] from the Apple menu.

2. Click [Printers & Scanners].

3. Select [Ricoh Cloud Printer], and then click [-].

4. Click [Delete Printer].

5. Click [Close].

For Google Chrome OS

1. On the "Extensions" screen, click [Remove from Chrome] for [Ricoh Cloud Print].

2. Click [Remove].

3. Uninstallation
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4. Sending a Print Job

Sending a Print Job to the Server of Cloud
Printing
This section describes how to send a print job to the server of cloud printing using a printer driver for
cloud printing.

• The user information setting screen appears in the following cases.

• Sending a print job for the first time after a client PC is started.

• [Save User Information] had not been selected when user information was set.

• Authentication failed.

• If a proxy server is used in the system environment, the proxy connection setting screen appears in
the following cases.

• Sending a print job for the first time after a client PC is started.

• [Save the password] had not been selected when user information was set.

• Authentication failed.

• For information about how to set the user and proxy connection information, see page 17
"Setting the User Information".

• It may take time to send a print job depending on the internet connection environment.

• Transmission may fail if sending a print job in an unstable internet connection.

• The authentication information specified in a printer driver will be invalid.

For Windows

1. On the [File] menu of an application, select [Print].

2. Select a printer, and then specify print settings.

3. Click [OK].

If the authentication succeeds, the print job is sent to the server of cloud printing.

For macOS

1. From the [File] menu of the application that you are using, click [Print].

2. At [Printer], select [Ricoh Cloud Printer], and then configure the print settings.
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3. Click [Print].

If the authentication succeeds, the print job is sent to the server of cloud printing.

For Google Chrome OS

1. From the keyboard, press and hold the "Ctrl" key and also press the "P" key.

2. At [Destination], select [Ricoh Cloud Print], and then configure the print settings.

3. Click [Print].

If the authentication succeeds, the print job is sent to the server of cloud printing.

4. Sending a Print Job
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Setting the User Information
This section describes how to set a user name and password on the user information setting screen and
the proxy connection setting screen.

For Windows

The user information setting screen appears in the following cases.

• Sending a print job for the first time after a client PC is started.

• Authentication failed.

User Information Setting Screen

When the login screen for RICOH Cloud Service is displayed, enter user information to proceed with
user authentication. The following authentication methods are supported, depending on the settings used
to install the printer driver:

• Email Address/Password

• Tenant ID/User ID/Password

• Microsoft 365 account

• SAML

• All

For information on how to use the login screen for RICOH Cloud Service, see "Login Methods" in the
"RICOH Workplace Administration Site Operation Guide".

https://na.accounts.ricoh.com/help/en/operation_guide/int/a0003.htm

Changing the account to be used

1. Before sending a print job, click [Product name] > [Delete User Information] on the
Windows [Start] menu to remove user information.

2. Send the print job.

3. When the login screen is displayed, log in with the account that you want to use.

Proxy Connection Setting Screen

If a proxy server is used in the system environment, the proxy connection setting screen appears in the
following cases.

• Sending a print job for the first time after a client PC is started.

• [Save the password] had not been selected when user information was set.

Setting the User Information
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• Authentication failed.

• Set the proxy server setting using the menu of Internet Explorer ([Tools] > [Internet Options] >
[Connections] tab > [LAN Settings]). Specify [Use automatic configuration script] in [Automatic
configuration], or [Proxy server].The operation of [Automatically detect settings] in [Automatic
configuration] is not guaranteed.

• Settings required on the proxy connection setting screen differ depending on the system settings.
For details, ask the administrator.

1. Enter a proxy user name in [User Name].

2. Enter a proxy password in [Password].

3. Click [OK].

• If selecting the check box of [Save the password] and then clicking [OK] in step 3, the entered
password is saved. The saved value is used from the next connection.

• If the authentication failed, the proxy setting screen appears. Enter the correct information.

For macOS

Set the user and proxy server information during the installation of the printer driver.

User Information Setting Screen

Enter the user information in "Login".

Using an email address to log in

To log in, use your email address and password as registered with the tenant.

1. Enter your email address in [Mail address].

2. Enter a password in [Password].

3. Click [Install].

If the authentication succeeds, the installation is performed.

Using an Office 365 account to log in

For information about how to use an Office 365 account to login, see the appropriate Microsoft
support page.

https://support.office.com/

Entering a User Name and Password and Logging In

To log in, enter your user name and password as registered with the tenant.

4. Sending a Print Job
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1. Enter a Tenant ID in [Tenant ID].

2. Enter a user name in [User Name].

3. Enter a password in [Password].

4. Click [Install].

If the authentication succeeds, the installation is performed.

Proxy Connection Setting Screen

If a proxy server is used, check "Use a Proxy Server" and configure the following settings:

Setting Description

Address Enter the address of the proxy server.

Port Enter the port number for the proxy server. Enter a number between 0 and
65535.

User name Enter the login user name for using the proxy server. The maximum length of
the name is 512 characters.

Password Enter the password for using the proxy server.

For Google Chrome OS

Enter the user information on the web browser's Extensions screen.

User Information Setting Screen

1. Click the Extensions ( ) icon on the web browser.

2. Click [Ricoh Cloud Print].

3. Click [Auth Settings].

4. Select an authentication type, and then enter the authentication information.

The following three authentication types are available:

Using an email address to log in

1. Select "Tenant ID/UID".

2. On "Input User Information", enter the tenant ID, user ID, and password.

3. Click [Login].

Setting the User Information
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Entering a User Name and Password and Logging In

1. Select "Mail Address".

2. On "Input User Information", enter the email address and password.

3. Click [Login].

Using an Office 365 account to log in

1. Select "Office 365".

2. On "Input User Information", click [Office365].

3. On the screen for Office 365 authentication, enter the necessary information.

For information about how to use an Office 365 account to login, see the appropriate
Microsoft support page.

https://support.office.com/

4. Click [Login].

4. Sending a Print Job
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5. Error Display
This section describes the error messages displayed when installing the printer driver and port monitor
for cloud printing or when sending a print job using a printer driver registered with the port for cloud
printing.

If errors which are not described appear, note the error, and then consult the customer service.

Error Messages

When Installing the Printer Driver and Port Monitor for Cloud Printing

Messages Causes Solutions

"Unable to run the installer
because of insufficient access
rights."

Installation is performed by a
user who does not have
administrator authority.

Operate with administrator
authority.

"The specified path is invalid." The number of entered
characters exceeds the
maximum number of characters
that can be specified for the
installation path.

Enter a valid path.

"The spooler service’s [Startup
Type] is disabled. Perform setup
after changing it to either
[Automatic] or [Manual]."

[Startup Type] setting of the Print
Spooler service is set to
[Disabled].

Perform the installation after
setting [Startup Type] to
[Automatic] or [Manual].

"Unable to start the spooler
service. Restart the OS."

The Print Spooler service cannot
be started.

Perform the installation after
restarting the client PC.

"Retry as a user with
administrator authority."

When the User Account Control
function is active, a user who
does not have administrator
authority performed installation.

Operate with administrator
authority.
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When Sending a Print Job

Messages Causes Solutions

"The file size is too large."

"Files to be uploaded should be
less than 300MB."

The file size of a print job to be
sent is over 300 MB.

Send a print job in size of not
more than 300 MB.

"Up to 50 files could be
registered."

50 print jobs are already stored
in the server of cloud printing.

Print/delete print jobs stored in
the server of cloud printing
before sending another print
job.

"Not connected to the network." Connections with the server of
cloud printing failed.

Check the network settings.

"A timeout has occurred." Timeout occurred in the
connections with the server of
cloud printing.

• Check the network settings.

• Send a print job again
after a while.

"A communication error has
occurred."

Unexpected error occurred in
the connections with the server
of cloud printing.

• Check the network settings.

• Send a print job again
after a while.

"Unable to connect to the
service."

The server of cloud printing is
down.

Consult the customer service.

"A system error has occurred." Office 365 account-based
login has failed.

Consult your administrator.

"Unable to connect to the
service."

Unexpected error occurred in
the server of cloud printing.

There may be a problem with
the cloud service. Please wait a
while, and retry again later. If
the problem persists, contact the
customer service.

"You do not have the authority
to read this page."

The user has no access to
Ricoh’s cloud printing service.

Consult your administrator.

"Failed to upload the file." Unexpected error occurred in
the port monitor.

There may be a problem with
the cloud service. Please wait a
while, and retry again later. If
the problem persists, contact the
customer service.

5. Error Display
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6. Appendix

Limitations
• For each port installed, up to five printer drivers can be registered for use. If more than five printer

drivers are registered, normal operation is not guaranteed.

• For multiple users to log into and use Windows, create a Windows user for each so that they can
respectively configure the printer driver with a port for cloud printing.

• If a port name is changed, reconfigure the printer driver accordingly.

• Sending of print jobs from a remote desktop is not guaranteed.

• Sending of a print job is not guaranteed if a user logged out of Windows while sending a print job.

• Operations are not guaranteed if the Windows operating system is upgraded (overwritten) when
the port monitor for cloud printing is installed (Ex: when the operating system is upgraded from
Windows 8.1 to Windows 10).

• Operations are not guaranteed if the edition of the Windows operating system is upgraded when
the port monitor for cloud printing is installed (Ex: when the edition of the operating system is
upgraded from Windows 10 Pro to Windows 10 Enterprise).

• Sending of print jobs using a printer driver other than a PCL 6 Driver for Universal Print is not
guaranteed.

• If sending a print job for printing multiple copies without sort setting, the number of copies cannot
be changed using cloud printing Embedded on an MFP.

• It may take time to send a print job depending on the internet connection environment.

• Transmission may fail if sending a print job in an unstable internet connection.

• Printing cannot be canceled if [Printing] is displayed for the status of a print job in a print queue of a
printer.

• When the User Account Control function is active, if sending a print job using the application which
is ran as an administrator, the user information setting screen/proxy connection setting screen/
error displays appear behind the application window.

• User information saved by selecting [Save the password] on the Proxy Connection screen can be
removed via the following steps:

1. On the Windows [Start] menu, click [Product name] > [Delete User Information].

2. On the Windows [Control Panel], open [User Accounts] > [Credential Manager] > [Windows
Credentials].

3. Remove the proxy authentication information from Credentials.
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Trademarks
Google and Chrome OS™ are trademarks of Google LLC.

macOS® is a trademark of Apple Inc., registered in the U.S. and other countries and regions.

Microsoft, Windows, Internet Explorer, and Office 365 are registered trademarks of Microsoft
Corporation in the United States and/or other countries.

The proper names of the Windows operating systems are as follows:

• The product names of Windows 10 are as follows:

Microsoft® Windows® 10 Home

Microsoft® Windows® 10 Pro

Microsoft® Windows® 10 Enterprise

• The product names of Windows 11 are as follows:

Microsoft® Windows® 11 Home

Microsoft® Windows® 11 Pro

Microsoft® Windows® 11 Enterprise

Other product names used herein are for identification purposes only and might be trademarks of their
respective companies. We disclaim any and all rights to those marks.
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